Quick start

This section introduces some basic features of FELIX 2004. After reading or working through this section, you will be prepared to start working with FELIX.

Quick start includes these tasks:

For more options on where to learn how to use FELIX, please see


Before working with FELIX

Before you begin, be certain that you have:

and

You should also be familiar with the following:


Typographical conventions

Unless otherwise noted, this guide uses these typographical conventions:

Select the File pulldown.


Starting FELIX 2004

There are two ways to start FELIX.

Note: When you start FELIX, you may have the following two choices depending on if you have run FELIX before and have saved the previous session in an environment file:
If you've saved the previous session, you are prompted by a RESTORE LAST SESSION dialog box. You may select to restore the previous session.
If you haven't saved a previous session, or if you choose not to restore the previous session, you will define a new .dba file or select an existing .dba file in the next OPEN DATABASE FILE dialog box.

Note: FELIX takes its "working directory" from the location of this .dba file. The "working directory" is the default location where FELIX looks for data files, opens matrices, etc.
To change the working directory with FELIX already running, use the Preference/Directory command.
You may also set a new default location for the working directory from the Windows Desktop. To do this, click the FELIX icon using your secondary mouse button (right-click). Select Properties from the popup menu. Click the Shortcut tab. Then, edit the content in the Start In: field to specify the new default working directory.


Processing a 1D spectrum

In this tutorial you will process a 1D NMR data set. Once you are comfortable with the procedures, this task takes approximately ten minutes to complete.

1.   Set up for the lesson

Create a folder on your hard drive to store tutorial files. Name the folder FELIX_Practice. For example:

c:\FELIX_Practice

Caution
Do not put the folder into the same path as the FELIX program files.

Locate the FELIX 2004 directory; it includes the FELIX 2004 executable file, felixwin.exe. If you use the default installation path, the directory is:

C:\Program Files\Accelrys\FELIX 2004

If you have trouble locating the installation directory, you can:

Right-click the FELIX icon on the Windows desktop. Click Properties. On the Shortcut tab of the popup, note the path listed for the Target parameter.

Navigate through the directory structure using the Windows Explorer program. To access Windows Explorer, right-click either the My Computer icon or the Network Neighborhood icon on your Windows desktop; select the Explore option.

Once you have located your installation directory, locate and open the tutorial subdirectory (folder). Next, locate the 1D folder. This folder contains the 1D data used for this lesson. By default, the 1D folder is located at:
C:\Program Files\Accelrys\FELIX 2004\tutorial\1D

Copy the 1D folder to the FELIX_Practice directory. (If you have not already created a directory called FELIX_Practice, please refer to .) To copy it quickly, right-click the folder and hold the button down. Next, drag the 1D folder to the FELIX_Practice folder and release the mouse button. Select the Copy Here option.

Caution

2.   Start FELIX.

Start FELIX by double clicking the FELIX icon on your desktop, or by clicking Start on the Windows taskbar, then selecting Programs/Accelrys/FELIX 2004/FELIX.

If FELIX prompts you to restore from last session, click Cancel.

FELIX displays an OPEN DATABASE FILE dialog box. Navigate to your working directory. If you use the default suggestion, this is:C:\FELIX_Practice\1D\Lesson1.

Enter a new filename (e.g., test) for a new, empty database. When you enter the name of a brand new database file, FELIX creates the file.

By default, where you open the database file becomes the current working folder. To change the working folder select Preference/Directory.

Select the File/Open command. Set the File Type parameter to Other Data [Bruker, Varian...].

Double-click the folder named 1. This is the experiment directory. From the contents of this folder, select the fid file. Click OK to confirm the selection. FELIX opens the file in the window.

This loads the data. The graphics frame displays a 32768 point FID, which we can now process.

Routine 1D data processing often consists of removing DC offset, multiplying the FID by an exponential window function, transforming the results into the frequency domain, and phasing the spectrum to obtain pure absorption peaks. Subsequently, baseline roll is removed and the spectrum is integrated. We follow these steps here.

3.   Remove DC offset

Select the Process1D/DC Offset command and choose Oversample DBC as Type. Click OK to perform the DC offset removal.

FELIX calculates a value for the baseline from the last 20% of the data points and subtracts that value from each data point.

4.   Apply Window Function

Select the Process1D/Window Function command to obtain a control panel that prompts for a window function. Enter Exponential as the Window function and click OK.

In the following control panel, enter 0.2 for Line Broadening and click OK to multiply the data by an exponential window function.

The display is updated to show the results.

5.   Fourier-transform the data

Now, transform the data from the time domain to the frequency domain using the oversampled transform (this data was collected as a Bruker oversampled spectrum).

Select the Process1D/Transform command. FELIX determines that the transform type should be Oversampled FFT. Click OK.

The result is a spectrum in the graphics frame. Notice that the spectrum requires some phase correction. This is most easily applied by first using the phase parameter values from the procs file.

Select the Process1D/Phase Correction command. Set the Method to Parameter and leave the Zero and First Order parameters at their current values (136.912 and 14.55447, respectively). Click OK.

This should produce an almost perfectly phased spectrum. If you need to adjust the phasing you can use the real-time phase interface.

To activate the real-time phase correction interface, select the Process1D/Phase Correction command and select the Real-Time option. Click OK.

You can change the pivot point by clicking Pivot and then clicking the desired spectral point. Usually the pivot point is at the lowest end (near the last peak) in the spectrum.

Use the REAL TIME PHASING dialog box to adjust the pivot point, the zero-order phase correction (Phase0), and the first-order phase correction (Phase1). Change the phase values by sliding either of the sliders left or right. These changes are visible in the display as you make them.

Since this is a modeless dialog, you can still activate the main menu and toolbar icons to adjust the display of the spectrum while the phasing dialog is on.

Repeat this with each correction until you are satisfied with the spectrum, then click OK to complete the phase correction.

This removes the real-time phase interface and makes the phased spectrum appear in the graphics frame.

6.   Perform the baseline correction

Select the Process1D/Baseline Correction command. Toggle on the Baseline Point selection. Leave the parameter at Auto Pick Points alone. Click OK.

In the next control panel, leave the Interval size at 128 and Maximum Deviation at 5. Click OK.

After FELIX selects the baseline points, it marks their locations with red tick marks at the bottom of the display frame.

In the BASELINE CORRECTION dialog, toggle the Baseline Correction to on and select the Polynomial option. Click OK.

When the dialog appears that prompts for the Polynomial order, keep the default of 5 (fifth-order polynomial). Set the Interval Width to 5. Click OK.

FELIX applies the polynomial function to the spectrum.

FELIX re-displays the BASELINE CORRECTION dialog. Click Done to close it.

7.   Integrate and display the data

The last step is to integrate the areas of the peaks and display the integrals as a cumulative sum.

Select the View/Draw Integrals command.

FELIX calculates the integral of all the peaks and displays the integral on the spectrum.If you want to integrate individual peaks, you can use the Measure/Integral and Volume command.

8.   Exit FELIX

To exit FELIX, select File/Exit to begin the shutdown sequence.

You either leave the Save Current Session and Save Current Database parameters on, or toggle them to off. Then click OK.

This shuts down FELIX. If you choose to save the current session and save the current database, FELIX saves the current session and the baseline points or integrals in the database file you selected when the program started.

You should now be familiar with the basic 1D processing features of FELIX and how to navigate through the menu system.


Processing a 2D spectrum

In this lesson you process a 2D matrix, display the spectrum using a variety of standard plotting methods, and assign the cross peaks. You start by processing a 2D matrix using the EZ macros. This lesson takes approximately 60 minutes to complete once you are comfortable with the procedures.

1.   Set up for the lesson

This lesson uses the 2D tutorial data set. When FELIX processes data it expects to see the data with the same directory structure as existed on the spectrometer. So, in this lesson you will copy a sample 2D dataset to your working directory.

Once you have located your installation directory, locate and open the tutorial subdirectory (folder). Next, locate the 2D folder. This folder contains the 2D data used for this lesson. By default, the 2D folder is located at:
C:\Program Files\Accelrys\FELIX 2004\tutorial\2D

Copy the 2D folder to the FELIX_Practice directory. (If you have not already created a directory called FELIX_Practice, please refer to .) To copy it quickly, right-click the folder and hold the button down. Next, drag the 2D folder to the FELIX_Practice folder and release the mouse button. Select the Copy Here option.

2.   Start FELIX

Start FELIX by double clicking the FELIX icon on your desktop, or by clicking Start on the Windows taskbar, then selecting Programs/Accelrys/FELIX 2004/FELIX 2004.

If FELIX prompts you to restore from last session, click Cancel.

FELIX displays an OPEN DATABASE FILE dialog box. Type the new filename in the File name field to create a new database file.

Where you create or open the .dba file determines your initial working directory.

Navigate to your working directory. If you used the default suggestion, this is:
C:\FELIX_Practice\2D\Lesson1.

Type file.dba in the File name field to create a new database file.

Instead of going directly to 2D processing, first we will apply a few 1D processing functions on the first FID in order to get some spectral parameters.

3.   Read in the first FID.

Select the File/Open menu item. Set the File Type parameter to Other Data (Bruker, Varian...). Double click on the 1 folder (the experiment directory) to open it. Locate and click on the ser file to select it. Click OK to open the file.

This file is the first FID of the 2D HSQC spectrum collected on a Bruker spectrometer.

4.   Apodize the FID.

Select the Process1D/Window Function menu item. Select Sinebell^2 as the apodization function.

In the next control panel, leave the default parameters (512 and 90.0) and select the Real-Time option for Method.

The FID is displayed along with the apodization function in red. You may experiment with different settings of the wsize and wshift parameters. The effect on the FID is displayed in real time.

Set the Window Size parameter to 512 and the Phase Shift parameter to 90. Then click Keep.

The apodized FID is now displayed on the screen.

5.   Transform the FID

Select the Process1D/Transform menu item. The default is Complex FFT. Click OK.

6.   Phase-correct the spectrum

Select the Process1D/Phase Correction menu item. In the control panel, select the Real-Time option for Method and click OK.

When the real time phase interface appears, click Pivot to select a peak to use for zero-order phasing. Using the mouse, adjust the Phase0 parameter to phase this peak, then adjust the Phase1 parameter as necessary. Click OK when you are finished.

Now that you have a rough idea of the apodization and phase correction parameters, you can proceed with processing the D1(t2) dimension of the 2D data set.

7.   Process the D1 (t2) dimension of the 2D data set

Select the ProcessND/Open and Process 2D menu item. In the first control panel, select the previous .ser file. In the next control panel, leave the header parameters at their default values (read from the spectrometer header files). They should look like these:

D1 Data Size 512
D1 Spectrometer Frequency 600.1408
D1 Sweep Width 7002.801
D2 Data Size 32
D2 Spectrometer Frequency 60.8
D2 Sweep Width 3000
Source Bruker

Click OK.

In the next control panel set the following parameter values:

Data Type Complex
Acquisition in D2 Echo/Anti-Echo

Click OK.

In the next control panel, set the following parameter values:

Dimension To Process D1 FT
Output Matrix Filename bruker.mat
Dimension 1 Size 1024
Dimension 2 Size 128
Correct DC-offset off
Correct 1st-point none
Solvent Suppression none
Window Function Sinebell^2
FT Type Complex
Phasing Mode Use Parameters
Phase0 -84.0
Phase1 0.0
Baseline Correction none
Reverse Vector off
Extract Half Spectrum Left Half
Output Level Verbose
Display Matrix on

Click OK.

When the Sinebell Parameters control panel appears, enter these values:

Data Size (Points) 512
Phase Shift (Degrees) 90.0

Click OK

There is a slight delay as the bruker.mat matrix is built. FELIX opens the bruker.mat matrix.

Click OK again to start the D1 transform.

As the D1 transform proceeds, the current row numbers are shown in the text window. This step should less than 1 second.

After the first dimension is processed, FELIX shows the control panel for processing the second dimension.

8.   Process the D2 (t1) dimension

Set the following parameter values in the control panel:

Dimension To Process D2 FT
Load Matrix in memory off
Processing Mode bundle
Correct 1st-point none
Solvent Suppression none
Window Function Sinebell^2
FT Type Complex
Phasing Mode Use Parameters
Phase0 0.0
Phase1 0.0
Baseline Correction none
Reverse Vector off
Extract Half Spectrum Left Half
Output Level Verbose
Display Matrix on

Click OK.

In the Linear Prediction control panel, set these parameters:

First Point 1
Last Point 32
Start Point 33
End Point 98
Number of Coefficients 8
Method Foward-Backward

Click OK.

In the Sinebell Parameters control panel , set these parameters:

Data Size (Points) 98
Phase Shift (Degrees) 90.0

Click OK

Click OK to start the D2 transform.

This step should take only a few seconds.

When processing completes, the matrix is open because you chose to display the matrix at completion. The contour threshold is calculated, and the matrix is then displayed.

9.   Display the 2D matrix

FELIX calculates the plot levels. You can change them manually:

Select the Preference/Plot Parameters menu item. Set the following values:

Contour Threshold 0.01
Cor Scheme Fire Ramp

Leave the other values set at their defaults and click Set.

Select the View/Plottype/Intensity menu item.

The full 2D spectrum appears.

FELIX always reads data from the matrix, not from a graphics file, so that it can recalculate display parameters at any time. Hence, FELIX redraws the graph with each plot command.

At this point you could examine the D1 and D2 vectors in more detail to determine if further baseline correction or phasing adjustments are necessary.

10.   Reference the matrix

Referencing of the matrix happens automatically, since the header parameters are read or adjusted during processing. You can further adjust the referencing, for example, by giving more descriptive names for the axis.

Select the Preference/Reference menu item. In the control panel, leave every parameter at its current value, except for these:

Spectrometry Frequency D1 600.14
Spectrometry Frequency D2 60.8
Axis TextD1 D1_HN
Axis TextD2 D2_N15

Click OK.

The 2D spectrum should now be redisplayed with the correct referencing for each axis.

11.   View an expanded-region contour plot

You can choose expanded regions with the cursor or by inputting numeric parameters:

Select the View/Limits/Set Limits menu item. When your mouse is positioned over the spectral window, FELIX changes the cursor into a white crosshair cursor.

Holding down the mouse button, drag a box around the region that you want to expand.

When you release the mouse button, the region selected expands to fill the window. The plot is still in intensity mode, hence the contour levels are not shown.

Select the View/Limits/Manual Limits menu item.

In the control panel that FELIX displays, the parameters are filled in with the values of the current plot.

Select the Preference/Reference menu item. In the control panel, leave every parameter at its current value, except for these:

D1_HN lower 7
D2_N15 upper 9
D2_N15 lower 104
D2_N15 upper 141
Limit Type ppm

Click OK.

The new 2D region appears.

You can save these parameters and reuse them for other plots. For example, if you were analyzing a series of spectra collected with different mixing times and always wanted to observe identical regions.

Select the View/Plottype/Contour menu item to redraw the region as a contour plot.

The 2D matrix is now plotted in contour mode, with individual contours colored as defined by your preference. Use the Preference/Plot Parameters command to change your display, as needed.

12.   Change the 2D drawing parameters

If no peaks are visible, try decreasing the contour level to cut lower into the spectrum. If the peaks are outlined but you do not see the circles shrinking to define the tops of the resonances (see ), try increasing the level multiplier to increase the space between levels:

Figure 1. Troubleshooting contour plots

13.   Show the grid display

To see the spectrum displayed with an evenly-spaced grid:

Select the Preference/Plot Parameters menu item. Click Axis. Set Grid Spacing to 3 and click OK.

Select the Preference/Plot Parameters menu item. Click Axis and then set Grid Spacing back to 0 and click OK.

14.   Pick peaks

First you need to set the peak-picking parameters. Select the Peaks/Pick Region menu item. Leave the parameters at their default values, but set the Pick Region Mode to Define by Cursor. Click OK.

Hold down the mouse button to use the cursor to drag out a box that includes the entire set of desired peaks.

Select the View/Limits/Manual Limits menu item.

FELIX displays red boxes around all cross peaks meeting the criteria defined in the control panel. After the peak picking is done, FELIX displays a spreadsheet, displaying all the peaks.

15.   Delete and replace peaks

Select the Peaks/Remove One menu item. The cursor becomes a +. Click one or two red boxes to remove them, then click <Esc> to return to a normal cursor.

Select the Peaks/Remove Region menu item. Drag a box around a few peaks to be deleted.

Select the Peaks/Pick Region menu item and repeat the dragging to add another region of peaks.

Select the Peaks/Pick One menu item and click to add individual peaks. Press <Esc> to return to a normal cursor.

Select the Peaks/Edit menu item to manually adjust the box defining a peak. Click the center of any red box of a picked peak. The box becomes green.

Click the center of the box and drag to move the entire box or click near a corner of the box and drag to resize it.

To leave editing mode, press the <Esc> key.

Select the View/Plot menu item to redraw the window (and clean up any broken lines or other details).

16.   Assign the cross peaks

Select the Peaks/Name One Peak menu item and click one of the red boxes. Set the following parameters to assign the resonance:

Item Number 148*
D1 peak namer h1
D2 peak name null

*Example integer only. The number in your display should match the number of the peak you select.

Click OK, then press the <Esc> key to return to a normal cursor.

You do not need to assign the peak in both dimensions. You can label the cross peaks in one dimension at a time, as the assignment is made. This is usually how assignments are observed.

If you want to use the restraints list directly in the Insight II or Discover program, you have to use the Insight II proton names as the peak names. At the moment there is no check of atom names, so you may enter anything you want.

17.   Display assignments

Select the Peaks/Find menu item, select Find Peak By Name and set the Action to Color. Set the Peak Name D1 to h1 and Peak Name D2 to *. Select Yellow for Color. Click OK.

FELIX searches the assignment list, and colors the boxes surrounding all peaks with a label of h1 in D1 dimension yellow.

18.   Calculate volumes

To calculate the volumes of the picked peaks, select the Measure/Integral/Volume menu item. In the control panel, select the Measure All Volume option for Action.

In the next control panel, leave the Peak and Volume set at their defaults. Set Volume Slot Number to 1 and Mixing Time to 0.1. Click OK.

FELIX displays a Building New Volume Entity control panel. Set Total Mixing Time Slots to 6 and click OK.

You can now view the volume data with the Edit/Table menu item (selecting the vol:volumes table) or write the volume data to a file with the File/Export/Table menu item.

To calculate restraints from these volumes based on the two-spin approximation, you must open or create a scalar entity for the database, define a scalar pair, create the restraints (strong-medium-weak, or any other listed choice), and write the restraints file. The appropriate commands are in the Measure menu.

19.   Quit FELIX

To quit FELIX, select the File/Exit menu item.


Writing your own macros

FELIX macros are the most powerful and innovative feature of this NMR processing software. By writing your own macros, you can automate anything that you can do with FELIX manually. Your ability to transform and manipulate data automatically using macros is limited only by your imagination.

FELIX 2004 comes with a library of macros capable of many common processing tasks. You can modify these macros to fit your specific needs.

Note: In addition to using macros for custom data-processing and data-analysis tasks, macros also define the parameters of the FELIX graphical interface. In fact, the advanced user may use macros to create control panels and menus in order to design a custom environment.

Chapter 4, "Macros" of the FELIX Command Language Reference provides much more information about writing macros. Its Appendix C, "Example Macros" provides many illustrations of macros and how to use them in FELIX. The two examples below are from this Appendix.

To write or edit a macro, it is easiest to use your system text editor. Any editor may be used as long as the resultant files do not contain formatting characters and do contain standard carriage control.

It is standard for the first line of any macro to contain the macro's name. However, this is optional.

FELIX ignores any macro line that starts with c**. The beginning of a typical macro is shown below.

Caution
The line numbers at left are used for reference only, and should not be included in the macro.
 

1    c**users.mac
2 set 0
3 dr
4 ...

Macros may also contain tab characters and blank lines, so that they may be organized to enhance readability. In addition, any characters that follow a semicolon (;) are ignored by the macro interpreter. This makes it easy to add comments to macros, as shown below in Lines 2, 4, and 17:

1 c**users.mac
2 ; Close all graphics frames:
3 fra zero
4 ; Open first graphics frame with a size of 100x100 pixels
5 fra open 10 10 100 100
6 ; Resize the frame to a size of 500x400 pixels
7 fra resize 10 10 500 400
8 ;
9 ; Open another frame with a size of 600x500 pixels
10 fra open 30 30 600 500
11 ; Set the first frame as the current frame:
12 fra front 1
13 ;
14 set 1 ;set all the points in work space to 1
15 ; performs a sinebell multiplication (size=all points,shift=90)
16 sb &datsiz 90
17 dr ;draw the sinebell window
18 ;
19 ret ;return to GUI or the caller macro
20 end

Please refer to the FELIX Command Language Reference for more in- depth guidance on writing FELIX macros. Online, find the FELIX 2004 documentation at this URL address:

Navigate to the FELIX 2004 documentation. Look for Appendix C, "Macros"; here you can view and print the file.

Note: If you are prompted for a username and password at the Accelrys documentation website, use the following:

Username: science

Password: faster


Sample Macros

Example 1:
eval_point.mac

; Macro evaluates a particular point in each
; vector of a serial 2D data file and stores
; output in a FELIX macro file. Macro presents
; example of using one macro to build another
; macro.
;
get 'Input Data File -->' inpdata
get 'Output Data File -->' outdata
get 'Data Point to Measure -->' point
get 'Number of Exps -->' num_exp
opn txt &outdata 0
for loop 1 &num_exp
re &inpdata
gv &point dataval
put &dataval
next
cls
end

Example 2:
lpf_d2.mac

; Simple macro to adjust the 1st point in a
; D2(t1)-vector of a transformed 2D matrix
; using LP. Removes missampling artifact in
; virtual acquisition. Caution, original
; matrix is overwritten.
;
get 'Specify matrix -->' mat
inq mat &mat exist
if &exist eq 0 then
ty Matrix &mat not found!!!
go scram
eif
;
cmx
mat &mat w
;
for row 1 &d1size
loa &row 0
hft
ift
lpf
ft
mul 2
red
sto &row 0
ty row=&row
next
scram:
ret
end


Using the FELIX database and spreadsheets


Introduction to the database utilities

In this lesson you will learn about the commands and functionalities of the database commands in FELIX.

1.   Start FELIX

Start FELIX by double clicking the FELIX icon on your desktop, or by clicking Start on the Windows taskbar, then selecting Programs/Accelrys FELIX 2004/FELIX 2004.

If FELIX prompts you to restore from last session, click Cancel.

The FELIX main window appears with an empty graphics frame, Frame  1.

FELIX displays the OPEN DATABASE FILE dialog box. Navigate to your working folder; then, type in a new filename (e.g., dba0) to open a new empty database.

The name of the database file (as well as the directory of the file) is displayed in the title bar of the FELIX main window, confirming its selection

The FELIX database has a hierarchical structure, illustrated in .

Files are composed of entities or tables whose structures are defined by schema files. The entities are in turn composed of items, which are themselves an arrangement of elements. The dba file system is difficult to understand in an overall sense, but one can begin to become familiar with it by working through some of the dba utilities, as in this lesson.

Figure 2. FELIX database hierarchical structure

2.   Close the current dba file and create a new one

Click inside the command text field at the bottom of the FELIX window. Enter the following commands (press <Enter> after typing each command), which closes the current dba file, creates a new one, opens it, and then lists the entities in the new dba file:

You should now see the following in the text window:

     item page name schema
---- ---- ---- ------
1 1 dba dba

which indicates that only the default (empty) database file exists.

Note: FELIX remembers up to 10 used commands. You can use the up or down arrow keys to browse through the last commands and edit one of them.

3.   Generate 2D cross peaks

Select File/Open, set File Type to Matrix (*.mat) and open any 2D spectrum (e.g., the one created in ). Select Peaks/ Pick Region to pick a small region of peaks.

The Peaks/Pick Region command knows how to render the data, even without your specifying a schema explicitly. This is because it knows which entity it requires and automatically uses the appropriate one (i.e., xpk.sch).

4.   Check the database file structure and see how it has changed

Select File/Open, set File Type to Matrix (*.mat) and open any 2D spectrum (e.g., the one created in ). Select Peaks/Pick Region to pick a small region of peaks.

You should now see the following in the text window:

     item page name schema
---- ----- ---- ------
1 1 dba dba
2 3 xpk dba

5.   View the contents of the entity xpk

Now enter:

You should see this in the text window:

     item page name schema
---- ----- ---- ------
1 5 peaks xpk

6.   Inquire about particular items and elements of the entity xpk:peaks

Enter:

FELIX displays a list of the cross peak footprints determined by the Pick utility. Until displayed, you can also view a table of the peaks' contents by using the Edit/Peaks menu item. This creates a special table that contains information about the peaks. You can use this table to edit the items or cells of the entity.

You can also specify the display of a particular item in an entity.

Enter:

Information similar to this appears in the text window:

     2 216.186 2.383 0 null 721.749 3.269 0 null

Next you specify a particular element in an item.

Enter:

Information similar to this appears in the text window:

     216.186

Since the element fields are named, you can use an equivalent command:

Enter:

The same information is displayed as for the preceding command:

     216.186

The other database utilities have the same syntactic logic.

7.   Load the value of an element

Now you load a value from the database using the name check.

Enter these commands:

The following value is displayed:

     216.186

You can change the value of any element in the database using an identifying number.

Enter:

You can also change the value of any element in the database by using names instead of numbers.

Enter these commands:

8.   Modify schema

You begin by copying one of the existing schema, asg.sch, to a new schema with the name wrd.sch. Then you edit this new schema file.

Note: To locate the FELIX schema files, locate the database folder in the path where the FELIX 2004 executable is located.
By default this path is:
C:\Program Files\Accelrys\FELIX 2004\database.
Open the database folder. Locate and open the folder called schema. Find the schema file you need.

Copy the existing schema, asg.sch, to a new file named wrd.sch in your working directory using Windows Explorer. Next use Notepad to edit the new wrd.sch schema file to the following:

c**wrd.sch
wrd 5
item i k 01 06 (1x,i5)
cenpnt r k 01 10 (f10.3)
wid r 01 10 (f10.3)
cenppm r k 01 10 (f10.3)
name c 32 34 (2x,a32)

Note that three numbers need to be changed in the last line.

The working directory is the folder where you created the database file. You can check or modify this by selecting Preference/Directory

9.   Pass data to and get data from a new database entity

Generate a new entity by entering this command:

This generates a new entity with the name weird, which is based upon the schema wrd.sch, using a single occurrence of that schema.

Store a value in an element of your new entity by entering:

Equivalently, you could also enter:

Both commands specify storing the string in the entity named weird, item 1, element 5 (again note that the element fields are named).

Give that element a name by entering:

Confirm that the element has been named by entering:

You should see the following:

Now read the ASCII file back in as another entity by entering:

Confirm the success of this set of operations by entering:

The following should be displayed:

To view any entity via tables you can use the Edit/Table menu item. This opens a control panel from which you can choose the entity that you would like to display in a table.


Closing files and exiting FELIX

To exit FELIX and return to your operating system, select the File/ Exit menu item.

If changes have been made to the FELIX database (which contains spectrum information such as cross peaks, baseline points, etc.), FELIX displays a dialog box prompting you to save changes before exiting.