Using Autoscreen


Lesson 1: Analyzing 2D 15N-HSQC spectra of calcyclin

This lesson presents the basic steps of SAR by NMR analysis using the Autoscreen module of FELIX. In this lesson you use a set of three 15N-enriched HSQC ser files of calcyclin acquired on a Bruker spectrometer.

The topics covered in this lesson are:

1.   Setting up for the lesson

If not done yet, set up the tutorial files as described in "Setting up tutorial files" in the preface, How to use this book. The files for are located in the Autoscreen\Lesson1 folder.

The files are briefly described below:

The exps.txt file is a list of input experiments and their associated structural files, with each line specifying the experiment ID, ser file (with path relative to /usr/people/cpeng/sarnmr/test/scripps/; see Step 3 for project paths), file type, structural filename (optional), and comments (optional):

     calcyclin	1/ser	serdemo	control
annexinXI_34 2/ser sertest.car test-1
annexinXI_48 3/ser sermols.txt

2.   Starting FELIX

Start FELIX by double-clicking the FELIX icon on your desktop, or by clicking the Start button on the Windows taskbar, then selecting Programs/Accelrys FELIX 2004/FELIX 2004.

If FELIX prompts you to restore from last session, click Cancel.

Change your Current Working Directory to C:\Felix_Practice\Autoscreen\Lesson1\ using the Preference/Directory... command. Build a new database by opening the File/New... command and choosing Create a new matrix or DBA file. Make sure the File Type is set to DBA(*.dba). Enter sar1 and click OK.

Tip: If you set up an Autoscreen project in the previous session and want to use the same spectrum display and scoring parameters as in that project, click OK in the RESTORE LAST SESSION dialog box.

Remember that spectrum-processing parameters are not inherited from session to session.

3.   Setting up the project

Select the Autoscreen/Project menu item from the FELIX menu bar. When you see the AUTOSCREEN PROJECT control panel, leave the default parameters unchanged (sar and 2D) and click OK.

You should see this in the status bar:

     Created new Autoscreen project 'sar'.
Note: Currently a project name is limited to less than nine lower-case alphanumeric characters. You can create only one Autoscreen project in a database file. Once a project is finished, you can select the File/New menu item to open a new database after saving the current one, and then repeat this step to create a new project.

The VERIFY DIRECTORIES control panel, which appears next, allows you to verify some important paths used to access or save the following files:

Raw spectrometer data files.
Processed matrix files.
ASCII files, including file list and results.

For this example, you are using relative paths for all experiments and molecular files, so it is important to verify the project paths.

Make sure that the paths in the VERIFY DIRECTORIES control panel are similar to the following:

Spectrometer Data:
C:\Kelix_Practice\Autoscreen\Lesson1

Matrix Files:
C:\Kelix_Practice\Autoscreen\Lesson1\analysis

ASCII Text Files:
C:\Kelix_Practice\Autoscreen\Lesson1\analysis

You can click Browse next to any of the paths to select a directory interactively or you can directly enter a directory name.

Click OK.

A new window containing an empty Experiments table is open and displayed to the left of the spectral window.

Note: By default, whenever a new window (table or spectral) is open, FELIX automatically re-arranges the layout of the windows.

You can turn off this feature by selecting Preference/Frame Layout from the main menu and set Action to None. You can also do the automatic re-arrangement at anytime by selecting Window/Auto Arrange.

When one or more table windows are open, only the menu and tool bar of the currently activated window are visible. If you want to select a certain menu item or tool bar icon, be sure to click the corresponding window first to activate its menu and tool bar (if any).

Remember

Tip: If you want to change the project paths again, use the Edit/Verify Directories menu item from the table or the Autoscreen/Experiment/Verify Directories item on the main menu bar.

4.   Adding experiments to a project

The following steps demonstrate three ways of adding experiments to an Autoscreen project.

Option 1 - Add one experiment at a time

Activate the spectral window and select the Autoscreen/Experiment/Add One menu item.

In the ADD ONE EXPERIMENT control panel, select Bruker (ser) as the Spectrum File Type, enter Control as the Experiment ID, and fill in the Comment with This is the control experiment.

If you want, you may turn on the Molecule toggle and click the Browse button. When the SELECT MOLECULAR FILE OR FILE LIST file browser appears, select demo.pdb and click OK to return to the ADD ONE EXPERIMENT control panel.

Finally, select the ser file under the directory 1, and click OK to add this experiment to the project.

The Autoscreen Experiments Table is updated with the newly added experiment.

The ADD ONE EXPERIMENT control panel is displayed again for you to add another experiment. Click Cancel to close it.

If you select a molecule file interactively, be sure to do so before selecting the ser file. Otherwise, FELIX does not "remember" that you selected the ser file and you will have to do it again.

Caution

Option 2 - Add experiments from all files in a directory

First clean up from your test of the previous option:

Highlight the row of interest (or all rows if you added more than one experiment) in the Autoscreen Experiments Table and select the Edit/Delete Experiments menu item to remove the experiment.

Next, add experiments from all files.

Activate the spectral window and select Autoscreen/ Experiment/Add All Files. In the ADD ALL EXPERIMENTS control panel, change To Dir to 3, the highest experiment number. Then click OK.

All three experiments are added to the project, with the first experiment taken as the control spectrum.

Tip: This function expects numbered Bruker experiments. If the experiments are not consecutively numbered, you can instruct the program to skip one or more between every two experiments, or it will automatically ignore nonexistent experiments.

Option 3 - Add all experiments listed in a file

First clean up from your test of the previous option:

Highlight all rows in the Autoscreen Experiments Table. From the table, select the Edit/Delete Experiments menu item to remove all the experiments.

Next, add experiments by reading a list in a file.

Activate the spectral window and select the Autoscreen/ Experiment/Add From File List menu item and, in the ADD EXPERIMENTS FROM FILE LIST control panel, select the file exps.txt and click OK.

This adds three experiments to the project, using the experiment list in the exps.txt file. These experiments are the ones that we will use in subsequent processing and scoring in this lesson.

5.   Processing a control spectrum

Unless you are using processed data, for example, FELIX matrices or Bruker 2rr files, one of the most important steps in using Autoscreen is processing the control spectrum. The processing parameters used during this procedure are used for the subsequent processing of all other test experiments.

Highlight the calcyclin experiment in the Autoscreen Experiments Table and select Action/Process Control Spectrum from the menu bar of the table.

Next you are guided through the processing of this 2D experiment. The procedure is similar to standard 2D processing in FELIX.

Keep the default parameters unchanged and click OK in the 2D HEADER INFORMATION and 2D ACQUISITION INFORMATION control panels.

In the 2D DATA PROCESSING control panel, which appears next, select Automatic for Phasing Mode and Facelift for Baseline Correction. click OK.

You will use the automatic phasing function (called PAMPAS) and baseline-correction function (called FACELIFT) after the Fourier transform.

Tip: PAMPAS automatically determines phasing parameters for a processed matrix. You will be prompted to set parameters for it later. If you want to phase interactively, select Interactive as the Phase Mode and enter 3 for Fid to Phase.

Click OK in the SINEBELL PARAMETERS control panel. If it warns you about overwriting an existing file, click Overwrite.

In the 2D DATA PROCESSING control panel, check Linear Prediction, select Automatic as the Phasing Mode, and Facelift as the Baseline Correction. Click OK.

In the GENERAL LINEAR PREDICATION control panel, change the Number of Coefficients to 8 and click OK.

Click OK in the SINEBELL PARAMETERS control panel.

In the AUTOPHASING (PAMPAS) PARAMETERS control panel, make sure Correct D1 and Correct D2 are checked. Under Excluded Areas, check #1. Click the Cursor button on the same line to set the excluded area interactively.

The purpose of this action is to exclude the water signals while determining the phase parameters. The cursor changes to a cross, allowing you to define a range to exclude for D1.

.

Click at a point between the real peaks and the water signals, keep the left mouse button depressed, and drag the cursor to the right limit of the spectrum (the Y coordinates do not matter), then release the mouse button.

The same control panel appears again with the excluded range displayed in points (for example from 374 to 512). If necessary, you can edit these numbers in the entry boxes.

Click OK.

The spectrum is automatically phased in both dimensions. In the output window, the determined phase parameters and other information are displayed.

Note:  

Finally, the BASELINE CORRECTION (FACELIFT) PARAMETERS control panel appears. Make sure D1 and D2 are checked for Correction Dimension and click OK.

The processed HSQC spectrum is now displayed as contours.

6.   Setting display reference and display limits

The spectral reference and display threshold are set using the general FELIX menu items or icons.

Select Preference/Reference from the main menu. In the REFERENCE MATRIX control panel, set these parameters:

Reference Point
D1: 462
D2: 64

Reference Shift
D1: 4.7
D2: 117.99

Axis Text
D1: D1_H1
D2: D2_N15

Click OK.

Use the Zoom icon on the FELIX tool bar to zoom in on the fingerprint area.

Select Preference/Plot Parameters. In the PLOT PARAMETERS-BASIC control panel, enter 0.025 as the Contour Threshold. Click OK.

Finally, select Autoscreen/Save Display and Reference to save the reference, limits, and threshold.

These parameters will be used for display, hardcopy, and scoring of all experiments in the project.

If you make any changes to these parameters, be sure to use Autoscreen/Save Display and Reference to save them -  otherwise the changes are lost. You can change the display threshold at any time (for example, after processing and scoring some test spectra), but the reference must be set before you select Autoscreen/Setup Scoring to define scoring parameters.

Caution

7.   Setting other display parameters

Many other display parameters can be changed and saved along with the project by selecting Autoscreen/Setup Display. These include the display parameters for the control spectrum and test spectra in contour mode and overlay mode and those for display of control peaks. For this lesson the default values are used.

Note:  

8.   Picking peaks and importing an assignment for the control spectrum

In the Autoscreen Experiments Table, double-click the Control spectrum to display it.

Activate the spectral window and select Peaks/Pick Region from the main menu and use the default parameters to pick all the fingerprint peaks.

About 82 peaks are picked and displayed in the Peaks-xpk:peaks table.

Tip:  

Select the Autoscreen/Import Assignments menu item. In the IMPORT ASSIGNMENTS control panel, select BMBR Assignment Table as the Assignment File Type and select the file bmrb_assign.tbl from the browser.

Click OK.

The output window reports that 17 peaks have been assigned. The assignments are also updated in the Peaks-xpk:peaks table.

`

To display the assignments on the spectrum, select Autoscreen/Setup Display, select Residue for Peak Labels, and click OK.

CautionThe bmrb_assign.tbl file is not a real or complete file and should only be used for demonstration purposes.

9.   Setup of scoring parameters

In this step you set up parameters for peak picking in and scoring of test spectra.

Select Autoscreen/Setup Scoring. In the 2D SCORING PARAMETERS control panel, click the Advanced button to review parameters in the ADVANCED PARAMETERS FOR 2D SCORING control panel. Leave all the default values unchanged and click Cancel to return to the 2D SCORING PARAMETERS control panel. Leave its default values unchanged and click OK.

For an explanation of the parameters for scoring, please see Chapter 1, Theory in the FELIX User Guide.

A Peak Displacement Table is displayed. The table contains the following columns:

Note:  

10.   Processing and scoring test spectra

Once you have set up the scoring parameters, you can process and score all the test spectra.

Select Autoscreen/Go from the Autoscreen Experiments Table.

The two test spectra are processed and scored against the control spectrum in turn, then a histogram of scores vs. experiments is displayed. The Autoscreen Experiments Table is updated with the scores and status of the test experiments.

Note:  

Experiment annexinXI_34 shows a higher score than the other experiment, which usually indicates a stronger binding of the ligand to the protein.

There are five methods for processing and/or scoring test spectra on the Action menu in the Autoscreen Experiments Table, which are used for different purposes. These are shown in Table 4.

Tip: The Peak Displacement Table is not updated at this moment. To display and update it for a certain spectrum, double-click it in the Autoscreen Experiments Table.

11.   Viewing clusters

Using the Autoscreen/View Clusters menu item groups experiments that share common displaced peaks, providing a way to locate the residues of the protein whose chemical shifts were affected by the close contacts of the ligand in different experiments.

Activate the spectral window and select Autoscreen/View Cluster, leave the default value of Cluster Threshold unchanged, and click OK.

The score matrix is displayed showing one cluster in green.

Move the crosshair cursor over the green area to display the peak number, experiment name, and contribution of that peak to that experiment. Press <Esc> when you are done.

Tip:  

12.   Analyzing the scoring results

Once you have an overview of all experiments, you can investigate the interesting experiments and interesting peaks.

First highlight Experiment annexinXI_34 (the one with the highest score) in the Autoscreen Experiments Table and click the Peak Contribution Histogram icon. Leave the default values in the PEAK CONTRIBUTION HISTOGRAM OPTIONS control panel and click OK.

A histogram of contributions vs. peaks for this experiment is displayed. The Peak Displacement Table is updated with the scoring data for Experiment annexinXI_34.

To view the peak displacements, double-click Experiment annexinXI_34 in the Autoscreen Experiments Table.

The overlay contours of Experiment annexinXI_34 over the control spectrum are displayed, together with the displacement arrows and control peak labels. The scoring results are also summarized in the output window.

To get a clearer view of the displacement arrows, you can:

Select Autoscreen/Setup Display to change the Peak Symbol, Peak Labels, and other settings.
Double-click the row of an interesting peak in the Peak Displacement Table to zoom in on that peak, or highlight several peaks in the table and click the Zoom on Peaks icon to zoom in on them. You can also use the Zoom icon on the FELIX tool bar or the <+> and <-> keys on your key pad to change the zoom ratio.

In the Autoscreen Experiments Table, click the Peak Contribution Histogram icon again to display the histogram of contributions vs. peaks of Experiment annexinXI_34.

Peak 73 has the largest contribution and seems to be an interesting peak.

On the Peak Displacement Table, click the Sort Contributions icon.

The peaks are now listed in descending order of their contributions to the score.

Highlight the first row, Peak 73, and click the Zoom on Peaks icon or simply double-click the row of peak #73.

The display zooms in on the displacement between control peak 73 and its matching test peak.

To display the titration of Peak 73, that is, its contributions in different experiments, highlight this peak in the Peak Displacement Table and click the Titration icon.

A histogram of contribution vs. experiments is displayed. This also shows that this peak has a much greater displacement in Experiment annexinXI_34 than in the other experiment.

13.   Manually editing scoring results

In the Autoscreen Experiments Table, highlight Experiment annexinXI_34 and click the Overlay icon.

Experiment annexinXI_34 is displayed over the Control spectrum together with the displacement arrows.

Click the Undo Sort Contributions icon in the Peak Displacement Table, then double-click peak 7 in the Peak Displacement Table to zoom in on the spectral area around it.

All control peaks appear to be correctly matched to the test peaks, so manually editing is not needed in this experiment. For demonstration purposes, the following operations assume that you do not like the currently matched test peaks for control peaks 7 and 8 and want to change them.

First select peaks 7 and 8 in Peaks Displacement table and click the Zoom icon so that peaks 7 and 8 are clearly visible.

To remove the current matching, select Edit/Remove Displacement from the Peak Displacement Table and click control peaks 7 and 8.

Press <Esc> to exit this mode.

This erases the displacement arrows.

Note: When you click <Esc> to exit a certain cursor mode, make sure that the spectral window is activated. If not, click on the title bar of the spectral window to activate it.

Now select Edit/Change Displacement from the Peak Displacement Table and click control peak 7.

Keep the mouse button depressed and drag the cursor to a location that you think is the best matching test peak and release the button.

Repeat this for control peak 8.

Press <Esc> to exit this mode.

This matches peaks 7 and 8 to the desired test peaks. All the changes you've made are reported in the output window and updated in the Peak Displacement Table.

Note:  

14.   Exporting scoring results

Activate the spectral window and select Autoscreen/Export Score. In the EXPORT SCORES control panel, set Contents to All Scores and Delimiter to Tab. Enter the filename Test2 as Filename (a .txt suffix will be added automatically).

Click OK.

All the experiments and their scores are listed in the Test2.txt file.

Repeat the previous box with Contents set to All Scores Sorted.

This lists all experiments and scores in descending order.

Repeat the first box of this step with Contents set to Scores and Titration, Number of Experiments set to 2, and Number of Peaks set to 10.

The scores of the top two experiments, in descending order of scores, and the contributions of the top 10 peaks that have the greatest sum of contributions to the two experiments are reported.

Note: This function is intended to give a summary of the "interesting peaks in the interesting experiments." You can choose the numbers of experiments and peaks to report.

<Shift>-click to select the two test experiments in the Autoscreen Experiments Table and <Ctrl>-click to select peaks 60, 63, and 73 in the Peak Displacements Table. Then repeat the first box of this step with Contents set to Titration Selected, Delimiter set to Tab, and Use Comments as Concentration toggled off.

The contributions of the selected peaks in the selected experiments are reported. Such a report is intended for calculation of Kd based on titration. If you have specified the concentration of the experiments in the comment column in the Autoscreen Experiments Table, you can toggle on Use Comments as Concentration to include that information in the report.

Repeat the first box of this step with Contents set to C2 QSAR Table.

All experiments and scores are listed in a format suited for QSAR study with the Cerius2 program.

To import Autoscreen results into Cerius2 for QSAR study, take the following steps:

1.   Start Cerius2. Select the QSAR deck and click the Show Study Table item on the QSAR card. This brings up a new, empty QSAR Study Table.

2.   In the QSAR Study Table, select File/Import... In the Import/Table control panel, uncheck File Contains Row Labels, check File Contains Column Labels, select the filename from the list box, and click Import. The experiments and score are displayed in the Table Manager.

15.   Scoring again with ROIs (regions of interest)

After getting an overview of all peaks in all experiments, you may want to focus on some interesting peaks in some interesting spectra instead of looking at all of them. When setting up the scoring parameters (see Step 9), all peaks in the Peaks-xpk:peaks table are taken as ROI peaks with weight equal to 1.0 by default. The following tasks demonstrate some of the methods for defining a subset of the peaks as ROI peaks.

Highlight the calcyclin spectrum in the Autoscreen Experiments Table and click the Draw icon to display it.

If the peak labels and peak numbers are not displayed, select Autoscreen/Setup Display from the main menu and choose Small Cross for Crosspeak Symbol and Number # for Peak Labels.

click OK.

Select Autoscreen/Define Region of Interest/Remove All to remove all peaks from the ROI set.

This sets all peaks as nonROI peaks with weight equal to 0. Note the change of their color in the spectrum window.

Select Autoscreen/Define Region of Interest/Add Region. Drag out a rectangle around the peaks with H1 chemical shift greater than 9.0 ppm.

Note the change of color of these peaks and the report in the status bar:

     Displaying 9 ROI peaks. Total 82 peaks.

In the Peak Displacement Table only these ROI peaks have non-zero weights.

Select Add One Peak. Click Peaks 1-5 and 73. Then press <Esc> to quit.

You have now about 15 ROI peaks. See the status bar again for the number of ROI peaks.

After defining ROI, you can rescore the spectra you are interested in. Highlight Experiment annexinXI_34 in the Autoscreen Experiment Table and select Action/Score Selected Spectra.

Its score is reduced to 2.285. Only the ROI peaks, displayed in yellow by default, show displacement arrows in the spectrum window. Both the Peak Displacement Table and the output window show the scoring contributions of the ROI peaks only.

Click the Peak Contribution Histogram icon with Experiment annexinXI_34 still highlighted, to see the histogram of the contributions of the ROI peaks. You can select either Peak IDs or Residue Numbers as the x coordinates.

To score all experiments based on the newly defined ROI peaks, select Action/Re-score All Spectra and click OK in the control panel.

Caution

16.   Printing spectra and histograms

To set up for printing, select File/Print Setup from the main menu. For example you may want to set Orientation as Landscape.

To get a print preview, select File/Print Preview.

To print either a spectral display, a histogram, or a table, select File/Print.

17.   Displaying molecules and scores in Insight II

To display experiments associated with a molecule, first start Insight II on a UNIX machine and navigate to the NMR_Refine module.

Next copy the demo.pdb file to the UNIX directory where you started InsightII. Select Molecule/Get, and choose PDB as Get File Type. Click Execute.

The protein molecule is displayed in InsightII.

Highlight the annexinXI_34 experiment in the Autoscreen Experiments Table. Select Action/Color Scores from the table.

In the COLOR RESIDUES BASED ON SCORE control panel, select InsightII as the Format and enter color as the filename.

Four assigned peaks with non-zero contributions are exported into file color.tab.

Copy the color.tab file to the UNIX directory where you started InsightII.

In Insight II, select Query/Color_By_SAR_Score. In the control panel, set these parameters:

Sar_Molecular_Name DEMO
SAR_Score_Filename color.tab
Neutral_Color white
Num_Intervals 10
Low_Score 0.02
High_Score 0.2

Click Execute.

Tip: If you are using Insight II version 980 or older, in which the Query/Color_by_Sar_Score command is not available, you can select File/Source_File to open the color_by_score.bcl script file to set up this command. The script file resides in the sar directory.

Wait until the rendering of the Connolly solid surface is complete. The residues that contribute to scores (between 0.02 and 0.2) are displayed in red. This may take several minutes.

18.   Exiting FELIX

To exit FELIX, select File/Exit.

Note:  


Lesson 2: Processing and Visualizing Multiple 1D spectra

This lesson presents the basic steps of analyzing multiple 1D spectra using the Autoscreen module of FELIX.

The topics covered in this lesson are:

1.   Setting up for the lesson

If not done yet, set up the tutorial files as described in "Setting up tutorial files" in the preface, How to use this book.

The files for this lesson are located in the Autoscreen\Lesson2 folder.

The files are briefly described below:

The exps.txt file is a list of input experiments and their associated structural files, with each line specifying the experiment ID, fid file (with relative path; see Step 3 for project paths), file type, structural filename (optional), and comments (optional):

control    1/fid  bruker_fid
testa_1 2/fid bruker_fid
testa_2 3/fid bruker_fid
testa_3 4/fid bruker_fid

2.   Starting FELIX

Start FELIX by double-clicking the FELIX icon on your desktop, or by clicking the Start button on the Windows taskbar, then selecting Programs/Accelrys FELIX 2004/FELIX 2004.

If FELIX prompts you to restore from last session, click Cancel.

Change your Current Working Directory to C:\Felix_Practice\Autoscreen\Lesson2\ using the Preference/Directory... command. Build a new database by opening the File/New... command and choosing Create a new matrix or DBA file. Make sure the File Type is set to DBA(*.dba). Enter sar2 and click OK.

Note: When FELIX starts you may need to adjust the size of the text window by clicking on its upper border and dragging it down a bit to see more of the upper spectrum display frame.

3.   Setting up the project

Select the Autoscreen/Project menu item from the FELIX menu bar. When you see the AUTOSCREEN PROJECT control panel, leave the Project Name unchanged (sar), change the Project Type to 1D and click OK.

You should see this in the status bar:

     Created new Autoscreen project 'sar'.
Note: Currently a project name is limited to less than nine lower-case alphanumeric characters. You can create only one Autoscreen project in a database file. Once a project is finished, you can select the File/New menu item to open a new database after saving the current one, and then repeat this step to create a new project.

The VERIFY DIRECTORIES control panel appears next. It allows you to verify some important paths used to access or save the following files:

Raw spectrometer data files

ASCII files, including file list

Processed 1D files (.dat files)

For this example, you are using relative paths for all experiments and molecular files, so it is important to verify the project paths.

Make sure that the paths in the VERIFY DIRECTORIES control panel are similar to the following:

Spectrometer Data:
C:\Kelix_Practice\Autoscreen\Lesson1

ASCII Text Files:
C:\Kelix_Practice\Autoscreen\Lesson1

Processed 1D Files:
C:\Kelix_Practice\Autoscreen\Lesson1

Click Browse next to any of the paths to select a directory interactively or you can directly enter a directory name.

Click OK.

Note:  

Tip: If you want to change the project paths again, use the Edit/Verify Directories menu item from the table or the Autoscreen/Experiment/Verify Directories item on the main menu bar.

4.   Adding experiments to a project

The following steps demonstrate three ways of adding experiments to an Autoscreen project.

Option 1-Add one experiment at a time

Activate the spectral window (click inside Frame 1 or on its top border) and select the Autoscreen/Experiment/Add One menu item.

In the ADD ONE EXPERIMENT control panel, select Bruker (fid) as the Spectrum File Type, enter Control as the Experiment ID, and fill in the Comment with This is the control experiment.

Double-click on directory 1, select the fid file, and click OK to add this experiment to the project.

The Autoscreen Experiments Table is updated with the newly added experiment.

The ADD ONE EXPERIMENT control panel is displayed again for you to add another experiment.

Select Cancel to close it.

Option 2-Add experiments from all files in a directory

First clean up from your test of the previous option:

Highlight the row of interest (or all rows if you added more than one experiment) in the Autoscreen Experiments Table and select the Edit/Delete Experiments menu item to remove the experiment.

Note: When you highlight the experiment table, the FELIX menu bar and icons are changed to reflect the options that are appropriate for use with that particular table.

To go back to the default menu bar, click inside Frame 1 or on its top border.

Next, add experiments from all files:

Activate the spectral window and select Autoscreen/Experiment/Add All Files. In the ADD ALL EXPERIMENTS control panel, change To Dir to 4, the highest experiment number. Then click OK.

All four experiments are added to the project, with the first experiment taken as the control spectrum.

Tip: This function expects numbered Bruker experiments. If the experiments are not consecutively numbered, you can instruct FELIX to skip one or more between every two experiments, or it will automatically ignore nonexistent experiments.

Option 3-Add all experiments listed in a file

First clean up from your test of the previous option:

Highlight all rows in the Autoscreen Experiments Table. From the table, select the Edit/Delete Experiments menu item to remove all the experiments.

Next, add experiments by reading in a list from a file:

Activate the spectral window and select the Autoscreen/Experiment/Add From File List menu item.

In the ADD EXPERIMENTS FROM FILE LIST control panel, select the file exps.txt and click OK.

This adds four experiments to the project, using the experiment list in the exps.txt file. These experiments are the ones that we will use in subsequent processing and scoring in this lesson.

5.   Processing a control spectrum

Unless you are using processed data, one of the most important steps in using Autoscreen is processing the control spectrum. The processing parameters used during this procedure are used for the subsequent processing of all other test experiments.

Highlight the first experiment in the Autoscreen Experiments Table and select Action/Process Control Spectrum from the menu bar of the table.

Next you are guided through the processing of this 1D experiment. The procedure is similar to standard 1D processing in FELIX (when using the Process1D/Open Process command).

Keep the default parameters unchanged and click OK in the 1D HEADER control panel.

The EZ 1D DATA PROCESSING control panel appears next.

Unselect both the Window Function option and the Phase Correct Option. Leave only the FT option selected and click Apply.

The spectrum is Fourier transformed and the EZ 1D Data Processing menu remains on the screen so you can try other processing combinations. You may need to adjust the position of the menu so that it doesn't obscure the spectrum.

Next, phase the spectrum.

Turn the Phase Correct option ON and set the Method to Real Time. Click Apply.

The spectrum is Fourier transformed. The phasing menu comes up.

Click the Pivot button. Using the cursor, click on the large peak near the center of the spectrum.

Next, using the zero order phasing slider adjust the large peak in the center until it is in phase. Then using the 1st order phasing slider adjust the right-most peak until it is in phase.

Note: You may have to click the Coarse button to get more range for the 1st order phase adjustment.

When the spectrum is in phase, click OK.

The phased spectrum appears and the processing menu is displayed again.

Change the Phase Correct Method to Use Current. Click Apply.

If you have properly setup the phasing parameters the spectrum will be transformed and phased properly at this point.

Note: The spectrum is still a bit noisy.

Now, apodize the spectrum, which demonstrates the interactive adjustment method.

Turn the Window Function parameter ON and set the Method to Sinebell squared. Click Apply.

When the Sinebell parameters menu displays, enter a Phase Shift value of 60.0 degrees and click OK.

When you click OK the EZ 1D Data Processing tool executes the processing choices you made. In this case it apodizes, transforms and phase corrects the spectrum. For many of the data processing choices you want to be able to try many different parameter combinations and visualize the result. The Interactive Processing choices allow you to interactively adjust most of the various processing parameters.

In the Interactive Processing group of buttons click on the Window button to interactively adjust the apodization parameters.

A window displays with sliders to allow you to adjust the number of points to apodize over and the phase shift.

For the Display Option select Digital FT.

This is the appropriate type of FT to use for this Bruker digitally oversampled data.

At this point the apodized fid, the apodization function and the transformed spectrum all appear on the display.

Experiment with various combinations of Window Size and Phase Shift and note the results on the transformed data.

You may also enter values directly in the parameter fields. Try a Window Size of around 512 points and a Phase Shift of about 70.0 degrees.

Click Keep when you are done adjusting the data.

In a real task, you would continue to adjust the processing parameter until you get a combination you like. At this point in the tutorial, finish the processing of the Control spectrum.

The EZ 1D Data processing menu displays again.

Click Apply. Verify that the correct apodization values are entered (512 and 70.0) and click OK.

The EZ 1D Data processing menu displays again.

Click OK.

This indicates that you are done with the processing and want to accept the parameters.

The Reference 1D Data menu appears.

Click the Cursor button and select the right-most peak.

In the Reference menu enter a value of 0.0 for the Reference PPM value and click OK.

6.   Processing all spectra automatically

Highlight the Autoscreen Experiments table by clicking on its top menu border. Then select the Action/Process/Reprocess All command from the menu bar.

You will see FELIX run through the processing of all the 1D spectra using the processing parameters you entered.

Next, demonstrate some of the visualization options for 1D spectra.

7.   Viewing and analyzing the 1D spectra

Click on the first row in the Autoscreen Experiments table.

You'll notice that this makes sure that the table is selected and the appropriate Autoscreen Experiment table menu items and icons are displayed.

Click the Draw icon. This displays the first spectrum in the table. Try using the Draw Next and Draw Previous icons. These icons scan through the various spectra and cause the next/previous spectrum to be displayed.

There are also various tools used to compare spectra.

Now use the overlay tool to compare a given spectra with the control spectrum.

Select the second row in the table by clicking on its item number. That row will highlight. Then click the Overlay icon. The control spectrum (row 1) is shown together with the selected spectrum. You may use the Overlay Next and Overlay Previous icons to compare other spectra with the control spectrum.

Note: The above example illustrates how to compare the control spectra (the spectrum used to define the processing parameters) with the other spectra. However, in many cases you need a more versatile tool to compare multiple spectra at one time. Use the Overlay Multiple icon to compare many different spectra at one time.

Select all rows in the experiment table: click on the first row item number and hold and drag the mouse down to the fourth row item number. Or, click on the row one item number then release the mouse. Then hold the shift key down as you click on the row four item number. Either of these methods should select all rows in the table.

Click on the Overlay Multiple icon.

The selected spectra appear on the display along with the 1D Overlay Setup menu. This menu allows you to select how many spectral combination to show on the screen. Each of these displayed spectra can be either an original spectrum or a subtractive combination of any of the spectra you selected from the Autoscreen Experiments table.

The Number of Spectra to Display parameter represents the number of these combinations which you wish to display at one time. The Spectrum Overlap parameter allows you to determine the extent of overlap. A "0.0" represents no overlap. A "1.0" represents total overlap.

Set the Number of Spectra to Display parameter to 3. This causes the first three rows to highlight.

For spectrum 1 leave the Method on A and the Spectrum A parameter as control.dat.

For spectrum 2 set the Method parameter to A-B, indicating that you want this second spectrum to be a subtraction. Set the Spectrum A to control.dat. Set Spectrum B to testa_1.dat which is the first test spectra.

For spectrum 3 leave the Method set to A and set the Spectrum A parameter to testa_1.dat.

Click Apply to see these three spectra.

You'll see that three spectra are displayed. The first is the control spectrum. The second is the control spectrum minus the first test spectra. The last spectrum in this group is the first test spectra.

Now, manipulate the data to make finer comparisons.

You'll notice that in row two of the 1D Overlay Setup menu that the Adjust button is not grayed out. Since this is a subtractive combination you can adjust the relative shift between the two spectra and the relative intensity of each one.

In row 2 of the 1D Overlay Setup menu, click Adjust.

A real-time adjustment menu appears where you can control the intensity of each of the two spectra being subtracted along with the relative shift in points between the two.

Note: Initially the intensity of the first spectrum is "1.0" and the intensity of the second spectrum is "-1.0". Since these two spectra are very similar the subtracted spectrum is mostly noise.

Try adjusting the shift between the two spectra and note the effect on the subtraction spectra in the center. You may also try adjusting the intensity of either of the two spectra which make up the subtraction.

To exit this routine click Quit to exit the real-time adjustment menu and then click Cancel to exit the 1D Overlay Setup menu.

This concludes the Autoscreen Lesson 2 tutorial on processing and visualizing 1D data.

8.   Exiting FELIX

To exit FELIX select Frame 1 and select File/Exit from the menu bar. Unselect the options to Save Current Session and Save Current Database.

Click OK to exit the program.